Domain Blacklist Issues
Incident Report for Abusix Intelligence
Resolved
Further to my last message, we've switched to using https://tranco-list.eu instead of the Majestic Million and added some additional pre-flight checks to the updater that collects and builds the domain whitelist from this data to prevent this issue from reoccurring.

The new whitelist data was then used to remove any domains that should not have been present in the domain blacklist, which was then manually checked and the zone is once again being built, so everything is now back to normal.

Once again, my sincere apologies for any inconvenience this caused.

Kind regards,
Steve.

--
Steve Freegard
Senior Product Owner
Abusix Intelligence
Posted Jul 29, 2019 - 10:59 UTC
Identified
We were recently made aware of several top domains being listed in the domain blacklist, which should not be possible given how we mask domains using the top million sites as a whitelist which is updated once per day.

Upon investigation, we have found that the list that we use (Majestic Million) on the last update returned 1 million domains (so passed all of our pre-flight checks), but looking at the actual data, would appear that they have a problem and the returned data was incorrect.

As we have no quick way to remedy this, I will be temporarily emptying the domain blacklist zone to prevent any further messages from being incorrectly blocked.

My sincere apologies for the inconvenience and I will send a further update once the problem has been fixed.

Kind regards,
Steve.

--
Steve Freegard
Senior Product Owner
Abusix Intelligence
Posted Jul 29, 2019 - 07:14 UTC
This incident affected: Cloud DNS and RSYNC.