Elevated response times
Incident Report for Abusix Intelligence
Resolved
Service and Response Times are back to normal. We apologize for any inconveniences.
Posted 4 months ago. May 30, 2019 - 11:13 UTC
Update
We are continuing to monitor for any further issues.
Posted 4 months ago. May 30, 2019 - 10:34 UTC
Monitoring
This morning we saw elevated response times on our AMI Cloud Infrastructure due to huge spikes of illicit requests. We suspect a DDoS. Everything is back to normal at the moment. We will keep an eye on the situation.
Posted 4 months ago. May 30, 2019 - 10:26 UTC
This incident affected: Cloud DNS.